Authentication issues on Manage.globalcashcard.com
Incident Report for Global Cash Card
Resolved
Duo appears to have fixed the issue. We will continue to monitor closely. Thank you.
Posted Jan 10, 2019 - 14:15 PST
Identified
We are currently experiencing issues with multi-factor authentication for the Manage web application (https://manage.globalcashcard.com). Our MFA provider, Duo, has reported that they are working on an active issue within their systems and are working diligently to resolve the problem. Once we've confirmed that services have been fully restored we will post an update.
Posted Jan 10, 2019 - 13:49 PST
This incident affected: Manage Website.