Phone lines down
Incident Report for Global Cash Card
Resolved
This incident has been resolved.
Posted Jun 06, 2017 - 07:11 PDT
Update
The phone lines for customer service have been restored. We will continue to monitor.
Posted Jun 05, 2017 - 23:40 PDT
Investigating
We are working on restoring phone services to our call centers. We apologize for the inconvenience and will post another message once the issue has been resolved.
Posted Jun 05, 2017 - 22:42 PDT
This incident affected: IVR and Call Center.